Fiber Outage - South Montrose Area
Incident Report for Elevate
Resolved
All services are now restored. We appreciate your patience as we worked to get fiber uplinks back up and running.
Posted Sep 02, 2023 - 21:47 MDT
Update
Service restored to roughly 75% of downed customers. Repairs are still ongoing. Thank you for your patience as our crews work to restore fiber connectivity.
Posted Sep 02, 2023 - 21:10 MDT
Update
Service restored to roughly 50% of downed customers. Repairs are still ongoing. Thank you for your patience as our crews work to restore fiber connectivity.
Posted Sep 02, 2023 - 19:43 MDT
Update
Fiber repairs are estimated to be completed in the next 2 hours. Thank you for your patience as our crews work to restore fiber connectivity.
Posted Sep 02, 2023 - 16:14 MDT
Update
The current time for repair completion is estimated at 4-6 hours. Thank you for your patience as our crews work to restore fiber connectivity.
Posted Sep 02, 2023 - 11:23 MDT
Identified
Dispatched field crews have identified fairly extensive fiber damage affecting south Montrose—no known cause at this time. Work to restore fiber connectivity is underway—no ETA for full restoration, presently.
Posted Sep 02, 2023 - 10:42 MDT
Investigating
Elevate teams have been made aware of a fiber outage affecting an area south of Montrose proper. Field techs are en route and we will provide updates and an ETA for service restoration as soon as possible. Thank you for your patience as we work to resolve this issue.
Posted Sep 02, 2023 - 09:41 MDT
This incident affected: Elevate Internet (Montrose) and Elevate Phone, Elevate TV.