TV Channels Heavily Distorted - ESPN Montrose County

Incident Report for Elevate

Resolved

This incident has been resolved.
Posted Feb 16, 2026 - 08:10 MST

Investigating

The Elevate Network Operations Center (NOC) has been made aware of heavy distortion and pixelation affecting the following channels in Montrose County:

ESPN

We are working to restore connectivity as soon as possible, thank you for your patience as we work through this.
Posted Feb 13, 2026 - 08:38 MST
This incident affected: Elevate TV.