Our upstream carrier has confirmed all systems are operational, and we have observed continous stability on our end. Please reach out to our tech support at 1-844-386-8744 if you are experiencing any issues. We thank you for your patience!
Posted 4 days ago. Mar 28, 2025 - 13:56 MDT
Update
Complete restoration efforts continue from upstream provider. Elevate Network Operations continues to monitor for stability. If you are experiencing any issues, please call 1-844-386-8744.
Posted 5 days ago. Mar 28, 2025 - 07:29 MDT
Update
The previously reported phone issue appears to have stabilized. We are continuing to monitor until a complete resolution has been reported from the upstream voice services provider.
Posted 5 days ago. Mar 27, 2025 - 21:01 MDT
Update
Our upstream partner has confirmed that their voice-related services are now stable. We are continuing to monitor the situation.
Posted 5 days ago. Mar 27, 2025 - 19:06 MDT
Update
Our upstream partners have confirmed that their services are now operational, and monitoring to ensure the network's stabilization. Thank you for your patience!
Posted 5 days ago. Mar 27, 2025 - 16:36 MDT
Monitoring
The Elevate NOC has been made aware of ongoing voice service related issues impacting all subscribers.
Our upstream partners are working to mitigate this event and will provide updates as soon as they have them. Thank you for your patience as we work through this degradation event.