Fiber Outage - Crawford Area
Incident Report for Elevate
Resolved
Service has been restored in the Crawford area. If you are experiencing any lingering issues, please get in touch with Elevate Network Operations and we will address it as soon as possible. Thank you!
Posted Oct 07, 2024 - 15:23 MDT
Update
Field service crews are still actively working to restore services. Customers are gradually coming online. Thank you for your patience!
Posted Oct 07, 2024 - 14:32 MDT
Identified
Field service crews have identified the issue and are currently working to restore services. There is no estimated time of completion at this time. Thank you for your patience!
Posted Oct 07, 2024 - 12:11 MDT
Investigating
Elevate teams have been made aware of a fiber outage affecting the area of Crawford. Field techs are en route and we will provide updates and an ETA for service restoration as soon as possible. Thank you for your patience as we work to resolve this issue.
Posted Oct 07, 2024 - 11:57 MDT
This incident affected: Elevate Internet (Crawford).