SW Crawford Outage
Incident Report for Elevate
Resolved
Elevate Crews have finished repairs in Crawford. All services are restored; please contact Elevate Tech Support if you are still experiencing issues. Thank you for your patience while repair efforts were underway.
Posted Jun 23, 2023 - 19:31 MDT
Update
Work on this fiber damage/outage is still ongoing, thank you for your continued patience.
Posted Jun 23, 2023 - 18:34 MDT
Update
Work on this fiber damage/outage is still ongoing. We appreciate your patience.
Posted Jun 23, 2023 - 16:15 MDT
Identified
Elevate field crews have identified fiber damage in the area and are working to repair asap.
Posted Jun 23, 2023 - 13:29 MDT
Investigating
Elevate crews are investigating an outage affecting a region in SW Crawford. Crews are on-site working to resolve the issue. We will post updates as they become available.
Posted Jun 23, 2023 - 13:12 MDT
This incident affected: Elevate Phone, Elevate TV and Elevate Internet (Crawford).