Elevate Data Services - Degraded - Montrose and Delta County

Incident Report for Elevate

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 20:21 MDT

Monitoring

Elevate Engineering has implemented a fix; we will continue to monitor network stability. Thank you for your patience as we work to resolve this issue.
Posted Mar 18, 2026 - 10:52 MDT

Investigating

The Elevate Network Operations Center (NOC) has identified a data traffic issue affecting subscribers in Montrose and Delta County. Our engineering team is actively investigating and working to resolve the problem.

Updates will be shared here as they become available. Thank you for your patience as we work to restore normal service.
Posted Mar 18, 2026 - 08:11 MDT
This incident affected: Elevate Internet (Montrose, Delta, Olathe, Cedaredge, Orchard City, Eckert, Austin, Hotchkiss, Paonia, Crawford).