Elevate Voice Service Issue
Incident Report for Elevate
Resolved
Call completion has proven stable since 1:30 MST. As of right now, this case is considered to be resolved. If you have any lingering issues, please contact our 24/7 Elevate Technical Support at 1-844-386-8744. We thank you for your patience!
Posted Apr 25, 2023 - 16:04 MDT
Monitoring
We are beginning to see successful call completion but are monitoring for stability.
Posted Apr 25, 2023 - 13:22 MDT
Investigating
We have been notified of an issue impacting successful call completion for both inbound and outbound calls from our upstream provider. We are investigating and will post updates as we receive them.
Posted Apr 25, 2023 - 12:16 MDT
This incident affected: Elevate Phone.