Elevate Internet Fiber Issue
Incident Report for Elevate
Resolved
The fiber damage has been repaired. If you are experiencing any isolated issues, please contact Elevate Technical Support at 1-844-386-8744. We appreciate your patience!
Posted Mar 03, 2023 - 12:17 MST
Monitoring
Elevate Network Operations staff have been informed of a partial fiber cut impacting approximately 50 subscribers on the south side of Montrose and on the southern outskirts of town. Splice crews are on site and repair efforts are underway. We will update the status of the repair efforts as we receive reports from field operations. We thank you for your patience during this time!
Posted Mar 03, 2023 - 11:31 MST
This incident affected: Elevate Internet (Montrose).