Elevate Voice Service Issue
Incident Report for Elevate
Resolved
After monitoring and testing, we have observed continued stability in the success of call completion. If you have any isolated issues to report, please contact Elevate Technical Support at 18443868744. We appreciate your patience!
Posted Feb 14, 2023 - 10:42 MST
Update
Elevate's upstream voice provider believes they have fixed the issue. Elevate is monitoring for stability to ensure restoration of service. We will update again once we have additional information. We thank you for your patience!
Posted Feb 14, 2023 - 10:33 MST
Monitoring
Elevate's upstream voice provider has identified an issue impacting the success of call completion both in and outbound. We are awaiting more information from our provider, and will post updates as we receive them. We thank you for your patience!
Posted Feb 14, 2023 - 09:53 MST
This incident affected: Elevate Phone.