Degraded Services
Incident Report for Elevate
Resolved
Maintenance is now complete.
Posted Feb 07, 2024 - 21:19 MST
Update
As a result of this evening's events, Elevate Engineering will be performing an unplanned maintenance. This is expected to be non-service impacting due to already implemented mitigation steps. We will continue monitoring and post updates as they come. Thank you for your patience as we work through this.
Posted Feb 07, 2024 - 20:15 MST
Monitoring
Elevate Engineering is reporting a stabilization of services. We will continue monitoring and post updates as they come.
Posted Feb 07, 2024 - 18:55 MST
Investigating
The Elevate NOC is aware of uplink issues impacting multiple areas within our territory. Investigation and mitigation is ongoing. Updates to come.
Posted Feb 07, 2024 - 18:19 MST
This incident affected: Elevate Internet (Montrose, Delta, Olathe, Cedaredge, Orchard City, Eckert, Austin, Hotchkiss, Paonia, Crawford, Dedicated Internet) and Elevate Phone, Elevate TV.