Fiber Damage Affecting Paonia
Incident Report for Elevate
Resolved
This maintenance is complete. If you are still experiencing any issues, please contact Elevate Technical Support for assistance. We appreciate your patience!
Posted May 21, 2023 - 13:25 MDT
Monitoring
The vast majority of the maintenance is complete, though there are a few residences without service. Crews continue to work today for full restoration.
Posted May 21, 2023 - 08:51 MDT
Update
Elevate crews are having to re-route fiber to restore services to affeced addresses. Expected time of restoration is midnight or after tonight. We will update as we know more. We thank you for your patience!
Posted May 20, 2023 - 17:21 MDT
Update
Elevate Crews are investigating alternative routes to feed members.
Posted May 20, 2023 - 15:17 MDT
Identified
Damaged fiber due to flooding. Crews are on site investigating restoration options.
Posted May 20, 2023 - 12:27 MDT
This incident affected: Elevate Phone, Elevate TV and Elevate Internet (Paonia).