Head End Equipment Issues - Paonia

Incident Report for Elevate

Resolved

Affected services have been restored. The Elevate NOC will continue to monitor this event and impacted subscribers for the time being. Thank you for your patience as we worked towards a resolution. Please reach out via our 24-hour tech support line if you continue to experience related service issues.

Elevate Tech Support = 1-844-386-8744
Posted Apr 22, 2025 - 12:53 MDT

Identified

The Elevate NOC has identified the failed head-end equipment and is implementing a fix. We will post updates as they become available. Thank you for your continued patience as we work to resolve this issue.
Posted Apr 22, 2025 - 11:41 MDT

Investigating

The Elevate NOC has been made aware of an outage event impacting an area of the Town of Paonia. Approximately 100 subscribers are down. Elevate head end equipment is suspected to have failed. Elevate NOC personnel are en route to investigate and repair. Updates regarding this outage will be posted here as they become available.
Posted Apr 22, 2025 - 11:27 MDT
This incident affected: Elevate Phone, Elevate TV and Elevate Internet (Paonia).