Upstream providers made half of the intended changes to restore functionality to the 970 West Plains Local Access channel. The next maintenance window to fully restore the channel broadcast will occur on March 4th. We appreciate your patience as we continue to work closely with our upstream carrier to restore service to this channel.
Posted Feb 26, 2026 - 10:31 MST
Update
Our upstream carrier has identified a head-end problem affecting the broadcast for this local channel. We have received a confirmed date for repair, which will be implemented on February 25th. We appreciate your patience as we continue to work closely with our upstream carrier to restore service to this channel.
Posted Feb 17, 2026 - 16:29 MST
Identified
The Elevate Network Operations Center (NOC) has identified an issue affecting TV service for subscribers in Montrose County. The following channel is currently unavailable:
-970 Local Access
We are working with our upstream partners to gather more information and restore access as quickly as possible.