Elevate TV Outage

Incident Report for Elevate

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 13:35 MDT

Monitoring

Services have been restored, and we will continue to monitor the situation.
Posted Jul 08, 2025 - 11:17 MDT

Update

Elevate Engineering identified the issue with an upstream carrier, and we are working with them to restore ElevateTV services.
Posted Jul 08, 2025 - 10:10 MDT

Identified

The Elevate NOC is aware of an outage on the Elevate TV Platform and is investigating the issue. We will provide updates as they become available. Thank you for your patience as we work to resolve this issue.
Posted Jul 08, 2025 - 09:34 MDT
This incident affected: Elevate TV.