Elevate Voice Service Issue
Incident Report for Elevate
Resolved
We have seen continued stability and improvements on the Elevate voice platform, and service is now considered to be fully restored. We will continue to monitor to ensure reliability. Please reach out to Elevate Technical Support if you continue to experience any issues. We appreciate your patience!
Posted Nov 30, 2022 - 14:20 MST
Update
Elevate is continuing to see positive signs of recovery. We are monitoring the situation closely to ensure stability. Elevate's upstream voice provider is also monitoring to verify everything remains operational. We thank you for your patience!
Posted Nov 30, 2022 - 13:24 MST
Update
Elevate is starting to see positive signs of recovery. We are monitoring the situation closely to ensure stability. Restoration efforts continue from Elevate's upstream voice provider. We thank you for your patience!
Posted Nov 30, 2022 - 12:13 MST
Update
Restoration efforts continue from Elevate's upstream voice provider. Elevate continues to monitor these efforts and will provide additional updates as we receive them. We appreciate your continued patience!
Posted Nov 30, 2022 - 11:48 MST
Update
Restoration efforts continue from Elevate's upstream voice provider. Elevate continues to monitor these efforts and will provide additional updates as we receive them. We appreciate your continued patience!
Posted Nov 30, 2022 - 11:13 MST
Monitoring
We have been notified from our upstream voice provider that there is a service-affecting issue impacting calls. The extent and duration of this issue are presently unknown. Their investigation and mitigation efforts are ongoing. Elevate is monitoring the situation and will provide updates as soon as we receive them. We appreciate your patience!
Posted Nov 30, 2022 - 10:38 MST
This incident affected: Elevate Phone.