TV Service Issues
Incident Report for Elevate
Resolved
We have received word of restoration of service, and have observed consistency on the TV product. We appreciate your patience!
Posted Oct 10, 2023 - 12:44 MDT
Monitoring
We have received word from our application developer that multiple channels are currently impacted by degraded video quality. We are in open communication with them and are monitoring the situation. We will post updates as they are available. Thank you for your patience.
Posted Oct 10, 2023 - 09:05 MDT
This incident affected: Elevate TV.