Upstream Voice Issue
Incident Report for Elevate
Resolved
We have observed continued stability on voice service over the weekend. We thank you for your patience during this time! If you have any issues, don't hesitate to reach out to our 24/7 technical support at 1-844-386-8744.
Posted Dec 04, 2023 - 08:59 MST
Update
Due to planned upstream maintenance, we are continuing to monitor phone services over the weekend. There is no downtime expected to occur at this time. Thank you for your patience!
Posted Dec 02, 2023 - 14:55 MST
Update
Our upstream provider has indicated that this issue is resolved. Elevate is continuing to monitor for stability and will assess periodically before closing this status.
Posted Dec 01, 2023 - 16:11 MST
Monitoring
Our upstream partners have identified the issue and implemented a temporary fix. Negatively impacted services should be restored at this time. The Elevate NOC will continue to monitor if anything changes. Please call Elevate technical support if issues persist.
Posted Dec 01, 2023 - 13:48 MST
Investigating
We are currently investigating and working with our upstream provider to identify and resolve issues with Voice services. Call routing and quality may be impacted at this time. We will post updates as they are available.
Posted Dec 01, 2023 - 12:53 MST
This incident affected: Elevate Phone.