Delta County Phone Service Outage - Elevate DSL

Incident Report for Elevate

Resolved

This incident has been resolved.
Posted Feb 16, 2026 - 16:05 MST

Monitoring

A fix has been implemented, and the Elevate Network Operations (NOC) will continue to monitor the stability and post updates as needed. Thank you for your patience as we worked to resolve this issue.
Posted Feb 16, 2026 - 09:49 MST

Investigating

The Elevate Network Operations Center (NOC) is aware of an ongoing issue affecting roughly 200 voice subscribers. We are actively engaging with our upstream voice service provider to identify the root cause and expedite resolution.

We will provide updates here as new information becomes available.

Thank you for your patience and understanding as we work to resolve this outage as quickly as possible.
Posted Feb 16, 2026 - 08:56 MST
This incident affected: Delta County Tele-Comm - Phone (Cedaredge, Orchard City, Eckert, Austin, Hotchkiss, Paonia) and Elevate Phone.