Elevate Phone Issue
Incident Report for Elevate
Resolved
We have monitored for overnight reliability and received word that our upstream provider's issues are resolved. If you are still experiencing issues, please contact our 24/7 technical support at 1-844-386-8744. We appreciate your patience!
Posted Apr 14, 2023 - 07:04 MDT
Monitoring
Elevate is seeing a restoration of call completion, and is monitoring for stability.
Posted Apr 13, 2023 - 18:00 MDT
Identified
We have been notified of an issue impacting successful call completion in both directions affecting all voice subscribers. We are monitoring the issue and receiving updates from our voice provider and will post updates as we learn more. We appreciate your patience during this time.
Posted Apr 13, 2023 - 15:37 MDT
This incident affected: Elevate Phone.