North West Montrose Facilities Damage.
Incident Report for Elevate
Resolved
Service has been restored. Thank you for your patience while Elevate crews worked to restore service to our members. If you are still experiencing issues please contact Elevate Technical Support.
Posted Jun 17, 2023 - 18:07 MDT
Monitoring
Elevate field crews are coordinating materials and personnel necessary for repair. Current estimated time of completed fiber repair is approximately 9:00 PM MST. As repair efforts continue, Elevate Network Operations will monitor the situation and post updates as they occur. We appreciate your patience!
Posted Jun 17, 2023 - 14:19 MDT
Identified
There is damaged fiber that is impacting multiple subscribers. Crews are currently investigating repair options. We will post updates once more information is relayed from field crews. Thank you for your patience as we work to restore services.
Posted Jun 17, 2023 - 13:12 MDT
Investigating
We are aware of a power outage causing issues in North Western Montrose. Crews are investigating if there is also fiber-related damage. We will post updates as soon as more information is available from field crews.
Posted Jun 17, 2023 - 12:45 MDT
This incident affected: Elevate Internet (Montrose, Olathe) and Elevate Phone, Elevate TV.