Paonia Fiber Issue
Incident Report for Elevate
Resolved
This fiber issue has been resolved. If you have any lingering issues, please contact Elevate Technical Support. We appreciate your patience!
Posted Feb 23, 2023 - 20:04 MST
Monitoring
Elevate crews have identified a fiber damage impacting approximately 60 customers. Crews are actively repairing this fiber. We are monitoring the situation and will provide updates as they occur.
Posted Feb 23, 2023 - 16:33 MST
This incident affected: Elevate Internet (Paonia).