Network degradation
Incident Report for Elevate
Resolved
All services have been restored. We appreciate your patience during this time. If you have any issues to report, please contact Elevate Technical Support at (844) 386-8744.
Posted Jan 18, 2024 - 11:12 MST
Update
Elevate Engineering has stabilized all internet traffic. We are monitoring over the next couple of hours to ensure consistent reliability. If you are still experiencing issues, please contact Elevate Technical Support at (844) 386-8744.
Posted Jan 18, 2024 - 06:19 MST
Update
Elevate Engineering has stabilized most internet traffic and is working toward stabilizing areas still impacted. We thank you for your continued patience while we work and stabilize all areas of our network. If you are still experiencing issues in the non-impacted areas, please contact Elevate Technical Support at (844) 386-8744.
Posted Jan 17, 2024 - 19:12 MST
Update
Elevate engineering staff continues to work on the issue. We will post updates as they are available.
Posted Jan 17, 2024 - 18:24 MST
Monitoring
Elevate Engineering has implemented a workaround to mitigate ongoing network issues.

The Elevate NOC will continue to monitor the situation and address reported issues on a case-by-case basis. Please open a ticket if you continue to have uplink issues; we will be happy to assist you as soon as possible.

We appreciate your patience as we continue to work through this.

-Elevate NOC Team
Posted Jan 17, 2024 - 11:12 MST
Identified
Elevate Engineering is continuing to work diligently to resolve these ongoing issues as soon as possible. Thank you for your patience while we work towards a solution.
Posted Jan 17, 2024 - 09:57 MST
Investigating
Elevate engineering is investigating an issue affecting the connection to some web pages and services. We apologize for the inconvenience.
Posted Jan 17, 2024 - 05:44 MST
This incident affected: Elevate Internet (Montrose, Delta, Olathe, Cedaredge, Orchard City, Eckert, Austin, Hotchkiss, Paonia, Crawford).