Power Related Network Outage in Cedaredge Area
Incident Report for Elevate
Resolved
The power-related network outage has been restored. If you are still experiencing issues, please contact Elevate Tech Support. Thank you for your patience.
Posted May 14, 2023 - 10:04 MDT
Identified
Due to unforeseen power-related events, we have a network outage affecting the Cedaredge area. Crews are notified and en route. There is currently no ETA on service restoration. The Elevate NOC will post updates as we are given information.
Posted May 14, 2023 - 09:17 MDT
This incident affected: Elevate Phone, Elevate TV and Elevate Internet (Cedaredge).