Denver Local Channel Issue
Incident Report for Elevate
Resolved
This issue has been resolved. All channels are back up and running. If you are still experiencing issues, please contact Elevate Technical Support. We appreciate your patience!
Posted Aug 29, 2023 - 10:59 MDT
Monitoring
Elevate has detected a loss of functionality on several Denver local channels, impacting TV subscribers in Delta County. We are actively working with upstream providers to restore services. We appreciate your patience!
Posted Aug 28, 2023 - 14:53 MDT
This incident affected: Elevate TV.