Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 01, 2023 - 01:00 MDT
Update
Due to a weather delay we will be canceling tonight's maintenance on the Denver local channels. We will proceed with the backup maintenance window for tomorrow night.
Posted Jul 31, 2023 - 11:03 MDT
Scheduled
We will be migrating the Denver local antenna array and encoders to a different location in downtown Denver. Denver locals will be offline during this maintenance window.