Fiber Line Damage - Delta County
Incident Report for Elevate
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 22:46 MDT
Update
We are continuing to monitor for any further issues.
Posted Jul 15, 2024 - 20:42 MDT
Monitoring
The fiber damage has been mitigated, and we are monitoring the situation.
Posted Jul 15, 2024 - 20:41 MDT
Identified
The Elevate NOC has been made aware of a large-scale outage in Delta County. Fiber damage is suspected due to a fire in the area, and field crews are en route to investigate and repair. Updates regarding this outage will be posted here as they become available.
Posted Jul 15, 2024 - 18:14 MDT
This incident affected: Elevate Internet (Delta, Cedaredge, Orchard City, Eckert, Austin).