Our field crews are finishing up repairs in the Delta County area, and services have been restored. Elevate's Network Operations will continue monitoring to ensure services are fully operational. Thank you for your patience.
Posted Mar 19, 2026 - 20:45 MDT
Update
Elevate Internet field crews have been cleared to begin working on fiber repairs. Repair work will be ongoing throughout this evening. An estimated repair time will be posted as more information becomes available.
Thank you for your patience as our field crews continue working towards full restoration of services.
Posted Mar 19, 2026 - 15:38 MDT
Identified
The Elevate Network Operations Center (NOC) has identified a large-scale service outage in Delta County. Preliminary reports indicate fiber damage due to fire activity near utility poles.
Our field crews are already en route to investigate and begin repairs after DMEA power crews give the all-clear. We will provide updates on this page as new information becomes available. We will post an estimated repair time as soon as possible.
We appreciate your patience as we work to restore service as quickly as possible.
Posted Mar 19, 2026 - 12:43 MDT
This incident affected: Elevate Internet (Delta, Orchard City, Eckert, Austin).