Outage - Southern Montrose Area

Incident Report for Elevate

Resolved

This incident has been resolved.
Posted May 22, 2025 - 16:45 MDT

Update

DMEA/Elevate field crews are continuing to work on restoring services related to this outage event. Further updates will be posted as they become available. The current ETR is now 5:00 PM. Thank you for your patience.
Posted May 22, 2025 - 15:01 MDT

Update

DMEA/Elevate field crews are continuing to work on restoring services related to this outage event. Further updates will be posted as they become available. The current ETR is still 4:00 PM. Thank you for your patience.
Posted May 22, 2025 - 14:02 MDT

Update

DMEA/Elevate field crews continue to work towards full service restoration. Our estimated time for completed repairs is 4:00 PM this afternoon. Apologies for the inconvenience this event has caused, and thank you for your patience as our crews work through this damage event.
Posted May 22, 2025 - 12:13 MDT

Identified

DMEA/Elevate field crews have located fiber damage, and restoration efforts are underway. Thank you for your patience as our crews work through this damage event.
Posted May 22, 2025 - 10:21 MDT

Investigating

The Elevate NOC has been made aware of an outage impacting the Southwestern Montrose Area. Fiber damage is suspected. Updates regarding this outage will be posted here as they become available. Thank you for your patience as we investigate this issue.
Posted May 22, 2025 - 08:58 MDT
This incident affected: Elevate Internet (Montrose).