Cedaredge Connectivity Issues

Incident Report for Elevate

Resolved

Elevate has implemented a solution to restore network connectivity to impacted Cedaredge customers. A restoration of internet services is expected at this time. If you have lingering issues, please call Elevate tech support at 1-844-386-8744.
Posted Dec 16, 2022 - 14:02 MST

Update

Elevate continues to investigate this issue. Thank you for your patience!
Posted Dec 16, 2022 - 13:27 MST

Update

Elevate continues to investigate this issue. Thank you for your patience!
Posted Dec 16, 2022 - 12:43 MST

Update

Elevate continues to investigate this issue. Thank you for your patience!
Posted Dec 16, 2022 - 12:02 MST

Update

Elevate continues to investigate this issue. Thank you for your patience!
Posted Dec 16, 2022 - 11:24 MST

Investigating

Elevate Network Operations and Engineering have been made aware of internet connectivity issues impacting customers in Cedaredge. Elevate is investigating the cause and will share more details as we find out more. We thank you for your patience as we work to identify and resolve this issue!
Posted Dec 16, 2022 - 10:40 MST
This incident affected: Elevate Internet (Cedaredge).