TV ESPN HD Channel 30 Pixelation Issues
Incident Report for Elevate
Resolved
The affected ESPN channels have been restored. The Elevate NOC will continue to monitor this event and impacted subscribers for now. Thank you for your patience as we worked towards a resolution. Please reach out via our 24-hour tech support line if you are continuing to experience related service issues.

Elevate Tech Support = 1-844-386-8744
Posted Jan 22, 2025 - 15:24 MST
Identified
We are aware of pixelization/resolution issues on ESPN HD Channel 030 and working to restore signal quality via satellite communications. We apologize for the inconvenience.
Posted Jan 17, 2025 - 15:21 MST
This incident affected: Elevate TV.