ElevateTV - Channel Outage - ESPN

Incident Report for Elevate

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 13:51 MST

Monitoring

Elevate Engineering has confirmed that service has been fully restored across all ESPN channels. Our NOC will continue to closely monitor performance to ensure stability. We appreciate your patience and understanding.
Posted Nov 21, 2025 - 16:35 MST

Investigating

We are currently experiencing an issue with the video transport network providing the ESPN channels. We apologize for the inconvenience and are working to identify and resolve the issue.
Posted Nov 20, 2025 - 14:37 MST
This incident affected: Elevate TV.