Degraded Phone Service
Incident Report for Elevate
Resolved
We have observed a full restoration of phone service. If you have additional issues, please contact our tech support at 1-844-386-8744. We appreciate your patience during this time!
Posted Mar 23, 2023 - 13:15 MDT
Update
We are monitoring a restoration of call completion, and are in close touch with our upstream voice provider to ensure stability. We will leave this status page up as we continue to monitor reliability. We will update as we receive updates. We thank you for your patience!
Posted Mar 23, 2023 - 12:23 MDT
Update
We continue seeing issues with the Elevate phone service impacting business and residential customers. The Elevate Net Ops team is in contact with upstream voice providers, and mitigation work is underway. We appreciate your patience while we continue to run these problems down with our upstream partners.
Posted Mar 23, 2023 - 09:12 MDT
Monitoring
A fix has been implemented and call completion should be returning to normal. Elevate staff is monitoring for stability. A maintenance will take place later this evening from our upstream voice provider to more fully address the issues at hand. We will continue to monitor for stability throughout the evening and will post updates as we continue to test and learn more. We thank you for your patience!
Posted Mar 22, 2023 - 16:32 MDT
Update
Our upstream voice provider continues restoration efforts toward re-establishing successful call completion for both inbound and outbound calls. Customers may experience intermittent success with inbound and outbound calls while they are continuing restoration efforts. We are monitoring this situation closely and will keep updating this page as we find out more. We appreciate your patience!
Posted Mar 22, 2023 - 14:16 MDT
Update
Our upstream voice provider continues restoration efforts toward re-establishing successful call completion for both inbound and outbound calls. Customers may experience intermittent success with inbound and outbound calls while they are continuing restoration efforts. We are monitoring this situation closely and will keep updating this page as we find out more. We appreciate your patience!
Posted Mar 22, 2023 - 12:50 MDT
Update
Elevate is monitoring our upstream voice provider's status and updates. We are observing impacts to call completion both inbound and outbound. Our upstream voice provider is aware of the issue and is actively implementing a fix for this issue. We appreciate your patience, and will continue to update this page as we find out more!
Posted Mar 22, 2023 - 11:01 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 22, 2023 - 10:27 MDT
Investigating
Elevate has been informed of an upstream phone service related incident that potentially impacts calls. Investigation is ongoing. Updates to come. Thank you.
Posted Mar 22, 2023 - 10:27 MDT
This incident affected: Elevate Phone.