Restoration efforts have been completed on the ElevateIQ app environment.
Posted May 19, 2025 - 15:53 MDT
Update
We've found the issue affecting ElevateIQ services and are working closely with the app developer to get everything back to normal. We apologize for the inconvenience and will keep you updated as we make progress.
Posted May 14, 2025 - 13:50 MDT
Identified
The Elevate NOC has been notified of an upstream software issue that is negatively impacting Elevate app subscribers. We are actively investigating this event and will post updates as they become available. Currently, these app-related issues do not seem to affect the overall service, we will continue to monitor and post updates as they become available.
Posted May 05, 2025 - 14:06 MDT
This incident affected: Elevate Internet (Delta, Olathe, Cedaredge, Orchard City, Eckert, Austin, Hotchkiss, Paonia, Crawford).